(Bug) Cannot play anymore

Hello everyone and like the title says this bug is preventing me from playing further :frowning: At first I started a pandora run, drafted my deck then launched the timer. When it found at match it bugged and nothing happen, after 2 mins I tried to click search the game told me it seems I was in-game so I had to log-out/log-in wich I did. Soon I logged in it loaded a match but showed no opponent and froze there, I tried closing the game/closing steam. I just don’t know what I can do now. I’ll check out later if it solved itself.

Having precisely the same issue. Any advice that anyone has would be greatly appreciated.

I’ve had a similar issue, but in ranked.

I q’ed up for a ranked/unranked battle and after a while the queue didn’t pop, but the timers went away. After this, when I tried to queue up again, it said that I was already in a battle and I should sign out then sign in again.
So I did that but now when I log in, my game is stuck on the “versus” screen but without my name or my opponents name on there.
Prior to this incident, I was in a game against an opponent where I tried to surrender during his turn, but then the game said he disconnected. After the disconnect timer went out, nothing happened and I had to reload the game. Now, I can’t play at all anymore

Issue appears to have resolved spontaneously. :slight_smile: