[Bug] Dropped connection did not end game

I was just in a Pandora game where my opponent lost connection. After 120 seconds (the allotted time) the window indicating that he had dropped connection disappeared but the game did not end. His timer in the lower right did not deplete while the window was open or after it vanished. The game stalled during his turn and I was unable to take any action. After roughly ten minutes, I exited the game. I reentered Pandora and did not seem to have received either a win or a loss the game.

This occurred at roughly 5:55 PM PDT (2:55 AM CEST).

Screenshot available upon request, but I don’t think it would communicate the issue.

i had faced this issue too, at similar time as OP. my creatures destroyed enemy orb, but game just stalled, and when i exited and re-entered the game, no win or loss was recorded.

I just had this same problem…

I’m not sure when it started hanging, but I tried to Surrender a Pandora match, but it didn’t seem to register. The turn timer froze and the game never ended. I eventually Exited the game, came back in and there was no win or loss registered.

At first I was able to click on the Play button for another Pandora match, but then it said I was ‘already in a match, try relogging’. I tried relogging, then when I clicked on ‘Pandora’ on the Main Menu it showed me the ‘Versus’ screen like I was about to enter another match, but there were no players on the ‘Versus’ screen and it never let me back into a match.

Now every time I get to the Main Menu it takes me straight to the blank ‘Versus’ screen. I can’t play any type of Faeria right now… Can’t even get into the Shop or the Deckbuilder.


Same with me! I was on a 10 win 1 loss run too! best ive even done but now I can’t finish it :frowning:

Just happened to me also. Opponent lost connection and timed out…but nothing happened. When I exited and came back in it was like nothing had happened.

Would be nice to fix.