[Bug] Not launching new match, not opening chests [Linux Mint 64]

The game starts normally, logs the user in, displays all the usual stuff.

When entering solo mode, it fails to start a new match:
The pictures of the possible choices (Fugoro, Seifer, etc.) get highlighted on mouse-hover, plays a little animation on click, but nothing happens after that - except it loses the mouseover highlight and does not react on any further clicks after the first. All matches are affected independently - clicking each one disables them separately. Exiting to main screen (by clicking the faeria rune in the top left corner) and then entering the solo mode again turns animation back on but still doesn’t allow to actually play.

Battle chests play sound and animation with the opening fireworks and stuff when clicked, but there are three things that should normally happen but don’t:

  1. UI should disappear leaving only the open chest and the new cards on screen.
  2. New cards should appear
  3. Number of chests available to the user should decrease by 1.
    As UI doesn’t disappear I am able to go to the main screen again and then return back to chests - their number does not decrease and they still not open.

These problems do also affect buying stuff - concretely the new adventure packs. After clicking “buy” a loading wheel appears, but never stops, so I have to hard kill the process.

All this can be solved by running “verify integrity of game files” in Steam, but only for the next launch of the game. If I close the game and start it again without rechecking the hashes - the problem reappears.
Interestingly enough - integrity verification does not report downloading any new files.

Given the fact that all the things affected have to do with server interaction I dare to assume it has something to do with establishing connection to game server (not the log-in, probably).
Given that the Steam really does not download any new files the only thing I can think of is some kind of cache having to do with connecting, probably?

Anyway, that’s the bug. I’m not sure what other info I can provide to help.

~ $ uname -a
Linux <hostname> 4.8.0-42-generic #45~16.04.1-Ubuntu SMP Thu Mar 9 14:10:58 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Please also consider submitting a bug report! Thank you for helping make Faeria a better game for us GNU/Linux players!

With all due respect, this is my bug report.

If you need me to go to do all the explanation from the beginning on another page - well, you can keep your thanks, I’m not paid for this stuff.

Also, I tried to find the bug-reporting page, and ended up writing a post here, so please also consider moving the report-a-bug button somewhere where it can be bloody found.

I have the same problem, too.

Just ended a match by lag-out . again . Hope I got credit for a win , but I don’t know – I can’t actually log back on.

super unsatisfying, when matches NEVER end appropriately and I am just immediately sent back to the log-on screen, without any victory or defeat screen.

the connection is on again, off again, god knows why or what.

recently had to reinstall because the game kept exiting from wrong buttons (CTD from ‘are you sure you don’t want to save your changes to your deck?’, from cancelling friends list…

The match I just played now, I had a ‘do you want to accept a friends suggestion?’ .??? I have no friends on my list !! a friends suggestion from whom, who isn’t on my list?? (I declined because that happened to me recently, and suddenly a VERY poorly placed mountain pops up. wtf??)


My opponent, BRANDON_NOW (I think,) may have been hacking my account once he realized he lost -_-;;;;

my account REEKS of hacker infiltration at this point