Faeria Crashing after new card introduction


I am a keen Faeria player on steam and have been for a while. I play on a Mac and after the latest update I am unable to launch the game, it loads to about 9/10th on the bar and then my computer bricks and I am forced to restart the computer. I managed to get 2 screens open and Faeria when launching doesn’t use much ram or cpu % but just bricks it as if it was using too much cpu. I run on a

Macbook Pro Mid 2012
Intel i5 2.5GHz
4GB 1600 MHz DDR3
Intel HD 4000
OSX 10.11.6

I never had a problem with the game before the update but now its just a pain.
I have checked the file integrity within steam with no solution.
If anyone can help or relate please give us a yell.

To me this sounds more like a hardware or system problem (although I’m definitely not sure of that).

Do you get a similar problem elsewhere? Can you play other games? Other unity games?

Does anything still work? e.g. does the cursor move / do other screens get updated / does game music keep playing / does external music keep playing?

I don’t know much about macs. Could it be corrupt video drivers? Have you tried updating them? Could you have hard disk issues (e.g. for system files)?

[quote=“BornPotato78, post:1, topic:7099”]as if it was using too much cpu[/quote]Not sure what you mean by that. Overheating?

Well it isn’t using all my cores like other games would. I get music and a cursor but im stuck on a loading screen. [quote=“Xaxazak, post:2, topic:7099”]
Other unity games?

As in Unity Engine games? I can run games like Eternal Winter which is built on the unity engine.

I reinstalled the whole game to no solution.

I forgot to note my OS. 10.11.6 (OS X El Capitan)

Can you update or reinstall video drivers? That’s all I can think of. I can’t help further, sorry.
You could submit a bug report, but maybe someone that knows more will reply here.