How to start Faeria on Fedora Linux


#1

Hello,

Faeria/Unity3D has been probably tested only on Ubuntu. Since I use Fedora, immediately after starting the game I was getting “The servers are currently unavailable” error. It was apparent that something is not right and the game does not even try to connect to the servers.

I noticed an error opening certificate bundle on path /etc/pki/tls/certs/ca-certificates.crt in the logging file located at /home/lzap/.config/unity3d/Abrakam Entertainment SA/Faeria/Player.log. Luckily, I know that this is not the right path for Fedora, probably on Debian/Ubuntu systems but in Red Hat based distros the CA certificate bundle which is used for HTTPS SSL/X509 communication the correct filename is ca-bundle.crt. I tried to create a symlink:

sudo su -
cd /etc/pki/tls/certs
ln -s ca-bundle.crt ca-certificates.crt
exit

And heck it worked! The game launched just fine, downloaded some additional resources probably via HTTPS connection and it works flawlessly.

So here it is. Have fun even on non-Ubuntu Linux systems. I know it’s bunch of work to test games on Linux as there are many distributions out there but I believe both Debian and Red Hat systems should be considered as primary platforms. This looks like a bug in Unity 3D, obviously the only supported platform is Ubuntu: https://forum.unity.com/threads/issues-with-unity-hub-on-fedora-30.767687/

Full disclosure: I am Fedora community member and contributor, Red Hat employee and I will keep using my Fedora for work. :slight_smile: I do most of my gaming on Windows, MacOS and PS4/Switch/3DS tho but Faeria is a great game to have an after lunch 15 min session break without rebooting. Good stuff.


Steam (Linux) always gives me The servers are currently unavailable