I can't download the latest patch

Hi, i got some problems whit the latest faeria patch, i can’t download it! Steam says “contents’ server not reachable”. I Tried to check the latest version of faeria, but the steam checking system is stuck to 0%. I tryed to unistall the game, but when i try to reinstall it, the problem is the same : “contents’ server not reachable”. I already contacted the faeria support team, and seems like they don’t even know what’s the problem. I’m looking for someone that can help me, or whit someone whit the same problem as mine.
I also tried to change the download region on steam, but nothing to do.
HELP :frowning:


The problem you experienced when you contacted the support team was due to our world server restart during the update back in December. If you are still experiencing the issue, the solutions that seem to solve the problem reliably for most people is:

  • Going to Steam > Settings > Downloads
  • The following page should be appearing

  • The first solution is to select a different “Download Region” and then restart Steam. Your download should be starting automatically once Steam is restarted. If that isn’t the case, try to verify the integrity of the game cache.
  • If that still doesn’t solve your issue you can clear the download cache on the same Downloads page

Let me know if that works for you.

1 Like

Actually, this morning i was able to download faeria, whitout doing anything, anyway if i’ll have the same issues, i’ll try and i’ll tell u. tanks

Whit every pach, i get the same problem. This time i tried both of your tips, but none of those did work, i tried to do everything, but nothing to do, every patch the same problem. i’m getting a bit bored.