Issues with solo Aurora Quest and Jalmyr Puzzle #20

Just to report some issues:

Aurora’s Quest seems a little unfair, the card Aurora’s teapot (changes all her creatures to 6/6) is a bit OP (hence it’s not available anymore) but still remains in this quest.

Jalmyr puzzle #20 is bugged. I do attacks and buffs in right sequence so that my buffed farmboy 5/1 attacks Jalmyr (5 health) but only registers as a 3 attack! Jalmyr survives with 2 health - mission busted! The 5/1 farmboy turns into a 3/1 after attack.

Of course the explanation may also be that I’m stupid - but I think it’s a bug!

Super game otherwise guys! Absolutely love it - keep up the great work.

Hello ^^

Just to mention that the card “Aurora’s teapot” has not been removed from the game : it is one of the Pandora’s treasures.

Concerning the difficulty of the quest, I don’t remember which ones of Aurora’s quests you’re speaking about so I can’t try again and remember how I’ve done to beat her.
But you can surely prevent her from having too much creatures on the board when she is able to use her teapot : have you tried to prevent her from collecting faeria, or to destroy her creatures before she could buff them (hellfire, firestorm, rushing creatures, etc…) ?

The guy who created this 7/7 aurora mission must die, just shoot him in back of his head, you’ll do a favor for all people.
You can’t kill this f**ing turtle with crappy deck and cards, why do you even made this mission, i tried like 30 times and i always lose, this crap is pissing me off, do something with this crap, its impossible to win there without some legendary cards, i tried like 6 decks and none of them worked.